[RESOLVED] Help! Getting terrible Wireless N speeds just 6-8 feet away
Results 1 to 11 of 11

Thread: [RESOLVED] Help! Getting terrible Wireless N speeds just 6-8 feet away

  1. #1
    Join Date
    Oct 2008
    Posts
    5

    Resolved [RESOLVED] Help! Getting terrible Wireless N speeds just 6-8 feet away

    I am having a hard time getting a good stable connection from my laptop's network card. I've tried different setups but it still isn't working. It keeps dropping down to 1Mbps per WWNCS (Windows Wireless Network Connection Status) and adding terrible delays.

    My old laptop which was only wireless G had much better stable and faster connection

    I have the following equipment
    Linksys 160N router
    Linksys WMP300N PCI on desktop
    Broadcom 4322AG 802.11a/b/g/draft-n Wi-Fi Adapter built into laptop

    My desktop PC connects fine and steady at 100mbps+ per the WWNCS and I can easily max out my connection if I run speed tests on DSL Reports.
    Also shows a very low Latency 10-20ms.

    However my Laptop connects around 1-2Mbps and once in awhile might go up 100Mbps+. I'm getting terrible download speeds and DSL reports speed test is just pathetic, like maybe 20-50% of my max connection speed.

    This is all like 6-8 feet away, open space. My desktop is more than 25 feet with 2 walls in between.

    The following are the current settings on my Network card:
    802.11h+d: Loose 11h+d
    802.11n Preamble: Mixed Mode
    Afterburner: Enabled
    AP Compatibility Mode: Higher Performance
    Association Roam Preference: Disabled
    Band Preference: None
    Bluetooth Collaboration: Enabled
    BSS PLCP Header: Auto (Short/Long)
    Disable Bands: None
    Fragmentation Threshold: 2346
    Locally Administered MAC Address: Not Present
    Location: United States
    Minimum Power Consumption: Enabled
    Mixed Cell Support: Disabled
    Power Output: 100%
    Priority & VLAN: Priority & VLAN Disabled
    Rate (802.11a): Best Rate
    Rate (802.11b/g): Best Rate
    Roam Tendency: Moderate
    Roaming Decision: Default
    RTS Threshold: 2347
    WMM: Auto
    WZC IBSS Channel Number: 11
    XPress (TM) Technology: Enabled

  2. #2
    Join Date
    Dec 2002
    Location
    Arizona, USA
    Posts
    4,750
    Have you been able to test the notebook against any other wireless network? That would go a long way in determining the functionality of that system.

    The other thing that may stick out some, is that it seems that your desktop settings appear to indicate that you have "cranked" up Linksys specific features, which your notebook may not support. That might lead to some of the difficulties that you are experiencing.

    802.11n is still not finalized as a standard, so there are no interoperability guarantees...
    Last edited by cszeto; 10-25-2008 at 09:13 AM.
    Microsoft MVP (2004 through 2008)

  3. #3
    Join Date
    Oct 2008
    Posts
    5
    Those settings are settings of my Laptop's network card.

    My desktop is as follows:
    Afterburner: Enabled
    Antenna Diversity: Auto
    AP Compatibility Mode: Higher Performance
    Bluetooth Collaboration: Disabled (no bluetooth on desktop)
    BSS PLCP Header: Auto(Short/Long)
    Fragmentations Threshold: 2346
    IBSS 54g(tm) Protection Mode: Auto
    IBSS Mode: 802.11a/b/g/b Auto
    Locally administered MAC Address: Not Present
    Location: US
    Minimum Power Comsumption: Enabled
    Mixed Cell Support: Disabled
    Power Output: 100%
    Priority & VLAN: Disabled
    Rate: Use best rate
    Roam Tendency: Moderate
    Roaming Decision: Default
    RTS Threshold: 2347
    WMM: Auto
    WZC IBSS Channel Number: 11(20MHz)
    Xpress (TM) Technology: Enabled


    As you can see the settings that they share are almost identical on both desktop/laptop.
    Also unfortunately I have not had a chance to test it against other networks, because I do not have access to them. However, I will be going up to my parents today and they have a straight wireless G network. I'll give that a shot.

  4. #4
    Join Date
    Oct 2008
    Posts
    5
    Also forgot to add:
    Both computers are running Windows Vista Laptop Premium 32, Desktop Ultimate 64. Only one wireless profile. Since I use disabled SSID broadcast, I use the following settings:

    checked -Connect automatically when this network is in range
    UNCHECKED - Connect to a more preferred network if available
    checked -Connect even if the network is not broadcasting

    Also I am only using Open WEP, since I need it for my Tivo (won't support WPA)

    Router is configured for:
    Network Mode: Mixed (B/G/N would go straight N if my other devices supported it PSP/NDS/WII/TIVO)
    Radio Band: Auto
    Wide Channel: Auto
    Standard Channel: Auto
    SSID Broadcast: Disabled
    Security Mode: WEP
    Encryption: 128-bit
    MAC Filter: Enabled

    AP Isolation: Disabled
    Frame Burst: Enabled
    Authication Type: Auto
    Basic Rate: Default
    Transmission Rate: Auto
    N Transmission Rate: Auto
    CTS Protection Mode: Auto

    Beacon Interval: 100ms
    DTIM Interval: 1
    Fragmentation Threshold: 2346
    RTS Threshold: 2347

  5. #5
    Join Date
    Dec 2002
    Location
    Arizona, USA
    Posts
    4,750
    It looks like the desktop and the notebook might be using similar chip sets, but since it is diffierent manufacturers and the 802.11n standard not being formalized, it still may be a contributing factor. Even with the 802.11g implementations, a lot of manufacturers add their own "spins" which only work within their own products.

    Verifying the notebook on another wireless network will go a long way in determining if you need additional support from the manufacturer(s) or just have a "borken" wireless adapter on your notebook.
    Last edited by cszeto; 10-25-2008 at 08:12 PM.
    Microsoft MVP (2004 through 2008)

  6. #6
    Join Date
    Oct 2008
    Posts
    1

    weak signal

    don't hide the SSid,it's already an old age wireless security....it will just give you poor wireless signal....changed the wireless channel on the router(it's using standard channel which is auto),try this..im 99.99% sure!

  7. #7
    Join Date
    Dec 2002
    Location
    Arizona, USA
    Posts
    4,750
    Actually, it's set as "auto" for multi-channeling, which was a 802.11g "trick" and also used on 802.11n as a "standard" way to get more than 54 mbps. Turning that off will probably improve performance, if that is part of the difficulties, but the overall wireless throughput will decrease accordingly.

    SSID hiding, is more of a setup issue. It never really worked from a security standpoint as there are clients that will still "see" and display the access point for connection.
    Microsoft MVP (2004 through 2008)

  8. #8
    Join Date
    Oct 2008
    Posts
    5
    well l am at my parents on a 54 g network and it seems to connect fine WNCS is showing mostly 54 mbps and remains steady. Most likely I have compatibility issues with my own router 'like you said N is still new and in draft state. Maybe that is why both my Linksys router and desktop PCI card works fine but my laptop Broadcom has problems.

  9. #9
    Join Date
    Dec 2002
    Location
    Arizona, USA
    Posts
    4,750
    Well, that's kind of "good news" in your current situation. You don't have any "broken" equipment, but if you want everything to work, you may need to "back down" to probably more "g friendly" settings on your router/access point.
    Microsoft MVP (2004 through 2008)

  10. #10
    Join Date
    Oct 2008
    Posts
    5
    I am back home right now. I turned off the N on my router and I am strictly running wireless G.

    My laptop seems alot more stable right now. Response times when accessing the internet is alot faster.

    My desktop's PCI card is wireless N with MIMO maybe that is overpowering my laptop's (non MIMO) signal while running in N mode.

    Regardless I don't really do much transfers between computers so, I guess 54mpbs (probably around 20 mpbs actual) will be sufficient enough for my internet connection. That was actually my main concern in the first place. It is just a shame that N hasn't been standardized or come near to be finalized anytime soon. Spending extra on a technology that doesn't work right yet

  11. #11
    Join Date
    Dec 2002
    Location
    Arizona, USA
    Posts
    4,750
    It is unfortunate with the whole "n situation" these days... Most "n" equipment do bring better range/distance performance when working with "g" equipment though...
    Microsoft MVP (2004 through 2008)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •