Wireless client won't pick up a DHCP lease
Results 1 to 4 of 4

Thread: Wireless client won't pick up a DHCP lease

  1. #1
    Join Date
    Feb 2006
    Posts
    6

    Wireless client won't pick up a DHCP lease

    Here's the setup:

    Tiscali ADSL into a 3Com OfficeConnect wireless router.
    1 desktop PC connected on 100Mb Ethernet works fine.
    1 laptop PC (Dell D600) picks up a DHCP lease with built-in Wlan card, works fine.
    1 desktop PC (self built Asus A8N-E AMD A64 +3700, 1GB Ram) with a Belkin F5D-7000 802.11g wireless card will not pick up a DHCP lease.

    The machine connects fine (with an SMC antenna) to the router when I give it a static IP address. Connection and throughput are stable.

    This problem happens whether I'm using the Belkin config software or Windows WZC service. I have the latest driver for the Belkin card, and the latest firmware for the 3Com router.

    I'm sure the router is fine because my laptop picks up a DHCP lease first time every time.

    The Belkin card worked in another machine when I had a Netgear 802.11b router, so I don't suspect it's faulty (especially since it carries traffic & connects to the router okay.)

    I'm going to try tracing the traffic with Ethereal to see if I can pick up the DHCP Request / Offer / Confirm packets, and will post the results.

    Any ideas?

    Jock in a Frock.
    Last edited by Jock in a Frock; 02-20-2006 at 09:39 AM.

  2. #2
    Join Date
    Oct 2002
    Location
    Great Britain
    Posts
    4,433
    The only thing that jumps to mind is the possibility that the router believes it already has an IP address allocated to the mac of the 11g card. A hard reset on the router may be worth trying to clear down its internal tables.

    Greenstead
    Only Human.

    TCP/IP File Sharing Checklist

    Wireless a/b/g

    If you are waiting a reply from me and none appears, Personal Message me to get my attention.
    Note: My views are based on my personal experience and do not represent practicallynetworked.com

  3. #3
    Join Date
    Feb 2006
    Posts
    6
    Nope, the router has had a firmware update and a factory reset folowwed by a full reconfiguration. The DHCP table in the router has not leased an address out for the MAC of the wireless card.

    I haven't had a chance to try a network trace yet.

  4. #4
    Join Date
    Feb 2006
    Posts
    6
    Fixed it!

    DHCP client and DNS client services were not running.

    Start / Run / Services.msc / DHCP Client / Startup Type = Automatic / Start

    Start / Run / Services.msc / DNS Client / Startup Type = Automatic / Start

    Now the PC DHCP's and DNS's like it should.

    I now remember turning these off before this PC was networked. I like to keep running services to a minimum to improve gaming performance, but it's cost me a ton of time trying to troubleshoot this problem. No-one to blame but myself, but hopefully this thread will help anyone else who comes up against the same problem.

    Jock in a Frock

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •